Incident History
MinorResolvedLasted 2 h 41 min
Transaction issues on Cardano blockchain
Affected · Deposits, Withdrawals, Wallet Services
Resolved — This incident has been resolved.
Sep 12, 2026, 23:24 GMT-3
Monitoring — A fix has been implemented and we are monitoring the results.
Sep 12, 2026, 23:23 GMT-3
Identified — The issue has been identified and a fix is being implemented.
Sep 12, 2026, 22:49 GMT-3
Monitoring — A fix has been implemented and we are monitoring the results.
Sep 12, 2026, 22:19 GMT-3
Investigating — Our transaction processing infrastructure is currently experiencing an issue that is causing a delay in finalizing transaction statuses for Cardano transactions.
Sep 12, 2026, 20:43 GMT-3
Started Sep 12, 2026, 20:43 GMT-3 · Resolved Sep 12, 2026, 23:24 GMT-3